It seems to work as usual and you should experience zero issues if you have the latest version downloaded from https://everhour.com/extensions.
Posted Sep 10, 2019 - 21:01 GMT+03:00
Monitoring
A fix is the Chrome store, please update it by going to everhour.com/extensions
Posted Sep 10, 2019 - 20:36 GMT+03:00
Identified
We have found that one of our recent updates has caused the problem of timer appearance on My Tasks and have released a fix to our extension. The ETA on it in chrome is 60 minutes, Firefox users can download it now from everhour.com/extensions
Posted Sep 10, 2019 - 20:19 GMT+03:00
Update
We are continuing to investigate this issue.
Posted Sep 10, 2019 - 20:13 GMT+03:00
Update
We are still looking into the problem why the timer does not appear in My Tasks section, please stay tuned for further update and thank you for your patience!
Posted Sep 10, 2019 - 20:12 GMT+03:00
Investigating
Hi, we are noticing problems to track time in Asana from the My tasks tab. Our team is on the case and we are trying to resolve the problem asap, thanks for your patience!