Timer is Missing from Task Details in New Asana Design
Incident Report for Everhour
Resolved
It seems the fix has brought the timer back to the task details in the new Asana design. Thank you all for your patience!
Posted Nov 21, 2019 - 11:08 GMT+03:00
Monitoring
We just uploaded the new version of our browser extension - 1.6.33. It should resolve all issues with new Asana task panel. Browser extension update will available in Chrome within an hour and already available to install in Firefox.
Posted Nov 21, 2019 - 01:10 GMT+03:00
Identified
Asana has released a new design to a task details view, which made our time disappearing from there. Right now we are waiting on the Asana team to give us access to that new design in order to deploy a fix.

We are sorry for any inconvenience, please track time using the timer on project page with all tasks, in our browser extension or through a Timesheet button.
Posted Nov 20, 2019 - 12:29 GMT+03:00
This incident affected: Browser Extension.