Web App and Extension are not working
Incident Report for Everhour
Resolved
We are glad to announce that the accident is fully resolved and under control now!

The problem appeared to be with excessive queries made by some of our users to our API. We have reduced the number of these queries and have contacted these users asking them to re-write their scripts.

We bring sincere apologies for an unexpected break in your workflow and say thank you all for your patience!
Posted Mar 17, 2020 - 17:34 GMT+03:00
Monitoring
A fix has been implemented and all should be operational at the moment. Our IT team is still identifying the real root of the accident and monitoring the performance.
Posted Mar 17, 2020 - 16:36 GMT+03:00
Investigating
Hi, we are facing problems with logging users in their Everhour accounts and the browser extension became non-operational too. Our team is on the case, thank you for your patience!
Posted Mar 17, 2020 - 16:10 GMT+03:00
This incident affected: App and Browser Extension.